WordPress 3.1.2 – Yet another Security Update

Ryan Boren announced that WordPress 3.1.2, a security release for all previous WordPress versions is now available. It is highly recommended that you update your blogs if you have multiple users registered. The issue was discovered by the famous Andrew Nacin, and Benjamin Balter.

The security vulnerability allows Contributor-level users to improperly publish posts.

This is a must update for anyone who allow users to register as contributors or if you just have untrusted users. This release also fixes a few bugs that were missed in version WordPress 3.1.1.

Have you upgraded now? If you haven’t, then don’t forget to follow our Ultimate Guide to Upgrade WordPress.